piroPAINT_9918

メニューについて

File メニュー

New

新規データを作成します。

ショートカットキーは「Ctrl+N」です。

New.png

「Image Size」項目のラジオボタンで画像サイズを選び、「Color」項目のラジオボタンで初期カラーを選択して「OK」ボタンを押すと、新規データが作成されます。
「Custom」の場合、作成出来る画像サイズの最大は640×640で、横8ドット、縦4ドット単位です。

「Color」項目のラジオボタンで「Color」を選択した場合、初期カラーはツールパレットのパレット色から選択します。

Open

画像データをファイルから読込みます。

ショートカットキーは「Ctrl+O」です。

8bit/4bitインデックスカラー及び、24bit以上のフルカラーBMPデータに対応しており、読み込み可能な最大ピクセル数は640x640です。

基本的に本ツールで作成したデータの読込みに使用します。
他のツールで作成したデータを読込める場合もありますが、その際の動作は保証されません。
右側にプレビューが表示されるものが読込可能なデータです。

※一部のペイントツールでは、BMPヘッダの情報が実ファイルサイズと異なっている事が原因で、本ツールで読み出せない場合がありました。
右側にプレビューが表示されない場合でも読込める場合があります。

ファイル読込み時に、使用カラーからVDPモードを自動検出し、カラーパレットが自動設定されます。

また、編集ウィンドウへファイルをドラッグ&ドロップすることでもファイルの読込みが可能です。

Save

現在編集している画像データをファイルに上書き保存します。

ショートカットキーは「Ctrl+S」です。

ファイルが既に存在している場合は、上書き(Overwrite)するかどうかを聞いてくるので、「OK」ボタンを押すと、保存を実行します。
「キャンセル」ボタンで保存をキャンセルします。

ファイル形式は、「BMP Color Depth」ダイアログで設定されるカラー深度に対応します。

これまでにセーブした事が無い場合(ファイル名が付けられていない場合)は、「Save As」と同じ動作を行います。

Save As

現在編集している画像データをファイルに保存します。

ショートカットキーは「Shift+Ctrl+S」です。

保存ダイアログが開くので、ファイルを選択するか、ファイル名を入力します。

ファイルが既に存在している場合は、上書き(Overwrite)するかどうかを聞いてくるので、「OK」ボタンを押すと、保存を実行します。
「キャンセル」ボタンで保存をキャンセルします。

ファイル形式は、「BMP Color Depth」ダイアログで設定されるカラー深度に対応します。

保存されるファイルのカラーパレットは、その時選択していたVDPの色が適用されます。

Save Consecutive

ファイル名の後ろに連番を付加して保存します。

ショートカットキーは「Ctrl+Alt+S」です。

現在編集している画像データをファイルに保存する際、ファイル名の後ろに日付の数字を自動で付加して保存を行います。

ファイルが既に存在している場合でも上書きの確認は行いません。

ファイル形式は、「BMP Color Depth」ダイアログで設定されるカラー深度に対応します。

これまでにセーブした事が無い場合(ファイル名が付けられていない場合)は、「Save As」と同じ動作を行います。

Quick Save

現在編集している画像データをメモリに保存します。

ショートカットキーは「F4」です。

Quick Saveした画像は、編集ウィンドウにフォーカスが当たっているときに、「F1」を押している間参照する事が出来ます。

下絵を読み込んでQuick Saveし、Newで新規画像を作成して、「F1」で下絵を参照しながらドットを打つ等の操作に有用です。

また、「99x8 Converter」にて「Apply」する時に、変換前の元絵をQuick Saveするオプションがあります。

このオプションを使用すると、変換後、元絵を参照しながらの修正が可能となります。

Quick Load

現在編集している画像データをメモリから読み込みます。

ショートカットキーは「F3」です。

Export

MSXで読み込み可能な形で SCREEN 2 のVRAMイメージを出力します。

詳細は、Export機能についてを参照して下さい。

Export.png

Exit

本ツールを終了します。

Edit メニュー

Undo

直前の編集をやり直します。(最大256段階)

ショートカットキーは、「Ctrl+Z」です。

※直前の編集とは、マウスの左ボタンを押してから離すまでの操作で行われた編集です。
また、New/Loadを実行した場合や、VDPの指定を切り替えた場合、PixelConverterを起動した場合は、Undo/Redoがリセットされます。

Redo

直前のUndoを取り消します。(最大256段階)

ショートカットキーは、「Ctrl+Y」です。

Copy

現在の画像をクリップボートにコピーします。

ショートカットキーは「Ctrl+C」です。

範囲選択は無く、画像領域の全てがコピーされます。

Color Depth

セーブ時のBMPカラー深度を設定します。

ColorDepth.png

4bit/8bit/24bitから選択します。
画像で使用されている色が16色以上の場合は、24bitに固定されます。

このダイアログは初めて画像をセーブする際にも開かれます。

Edit Mode

編集モードを設定します。

EditMode.png

モードは「99x8 (1:1)」、「PC-6x01 (2:1)」、「PC-6x01 (1:1)」があります。
括弧内の数字はドット比です。

それぞれのモードに応じて、パレットも切り替わります。

View メニュー

Tool Palette

ツールパレットウィンドウの表示・非表示を切り替えます。

ショートカットキーは「Ctrl+T」です。

ToolPalet1.png

Message

メッセージウィンドウの表示・非表示を切り替えます。

ショートカットキーは「Ctrl+M」です。

Message.png

Grid

8ドット境界を示すグリッドの表示・非表示を切り替えます。

ショートカットキーは「Ctrl+G」です。

Tool メニュー

Color Check

現在編集している画像データが「9918ルール(横8ドット中2色まで)」の通りになっているかを確認するツールです。

ショートカットキーは、「Ctrl+TAB」です。

使用されているカラーパレットと、色数をチェックを行い、問題があればエラーログのダイアログを表示します。
エラーは最大20件まで表示されます。

「Free Draw」モードで描かれた画像や、他のツールで作成した画像データを読込んでチェックする場合に使用します。
また、Exportする際にもカラーチェックが行われ、画像データにエラーが無い場合のみバイナリデータが出力されます。

「Color Check」でエラーがある場合は、「TAB」キーを押している間エラー箇所がピンク色で明示されます。
(エラーが無い場合は、TABキーを押しても何も表示されません)

Pixel Converter

画像変換ツールを起動します。

詳細は、PixelConverterについてを参照して下さい。

PixCnv-9918.png

Help メニュー

About

本ツールについての情報ダイアログボックスを表示します。

About.png

ダイアログボックスに記載されているWEBアドレスはリンクになっています。
クリックすると、デフォルトブラウザでページが開きます。

Help

この操作説明WikiページをOSのデフォルトブラウザで表示します。


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2014-08-24 (日) 07:18:13 (1570d)